DNS (Domain Name System)
Pengertian DNS
(Domain Name System ; DNS) adalah sebuah sistem yang menyimpan
informasi tentang nama host ataupun nama domain dalam bentuk basis data
tersebar (distributed database) di dalam jaringan komputer, misalkan:
Internet. DNS menyediakan alamat IP untuk setiap nama host dan mendata
setiap server transmisi surat (mail exchange server) yang menerima surel
(email) untuk setiap domain. Menurut browser Google Chrome, DNS adalah
layanan jaringan yang menerjemahkan nama situs web menjadi alamat
internet.
DNS menyediakan pelayanan yang cukup penting untuk Internet, ketika
perangkat keras komputer dan jaringan bekerja dengan alamat IP untuk
mengerjakan tugas seperti pengalamatan dan penjaluran (routing), manusia
pada umumnya lebih memilih untuk menggunakan nama host dan nama domain,
contohnya adalah penunjukan sumber universal (URL) dan alamat surel.
Analogi yang umum digunakan untuk menjelaskan fungsinya adalah DNS bisa
dianggap seperti buku telepon internet dimana saat pengguna mengetikkan
www.indosat.net.id di peramban web maka pengguna akan diarahkan ke
alamat IP 124.81.92.144 (IPv4) dan 2001:e00:d:10:3:140::83 (IPv6).
Sejarah DNS
Sebelum dipergunakannya DNS, jaringan komputer menggunakan HOSTS.TXT dari SRI (sekarang SIR International) yang
berisi informasi dari nama komputer dan IP address-nya. Di Internet,
file ini dikelola secara terpusat dan di setiap lokasi harus di copy
versi terbaru dari HOSTS files, dari sini bisa dibayangkan betapa
repotnya jika ada penambahan 1 komputer di jaringan, maka kita harus
copy versi terbaru file ini ke setiap lokasi.
Dengan makin
meluasnya jaringan internet, hal ini makin merepotkan, akhirnya
dibuatkan sebuah solusi dimana DNS di desain menggantikan fungsi HOSTS
files, dengan kelebihan unlimited database size, dan performace yang
baik.
Paul Mockapetris menemukan DNS di tahun 1983; spesifikasi
asli muncul di RFC 882 dan 883. Tahun 1987, penerbitan RFC 1034 dan RFC
1035 membuat update terhadap spesifikasi DNS. Hal ini membuat RFC 882
dan RFC 883 tidak berlaku lagi. Beberapa RFC terkini telah memproposikan
beberapa tambahan dari protokol inti DNS.